On Thu, Apr 07, 2022 at 12:14:26PM +0300, Jani Nikula wrote:
Ever so slowly moving towards cleaner EDID reading.
Jani Nikula (12): drm/edid: convert edid_is_zero() to edid_block_is_zero() for blocks drm/edid: have edid_block_check() detect blocks that are all zero drm/edid: refactor EDID block status printing drm/edid: add a helper to log dump an EDID block drm/edid: pass struct edid to connector_bad_edid() drm/edid: add typedef for block read function drm/edid: abstract an EDID block read helper drm/edid: use EDID block read helper in drm_do_get_edid() drm/edid: convert extension block read to EDID block read helper drm/edid: drop extra local var drm/edid: add single point of return to drm_do_get_edid() drm/edid: add EDID block count and size helpers
Some of the stuff was a bit hard to follow, but I suppose that's mostly an indication of the messy state of the current code. Didn't spot anything obviously wrong at least.
Series is Reviewed-by: Ville Syrjälä ville.syrjala@linux.intel.com
drivers/gpu/drm/drm_edid.c | 350 ++++++++++++++++++++++++------------- 1 file changed, 225 insertions(+), 125 deletions(-)
-- 2.30.2