Dear Maarten, I see it from the cgit.freedesktop.org, our sprd drivers seems has been merged into drm-misc.
Now, what shall we do next?
BR, Best wishes
Kevin Tang kevin3.tang@gmail.com 于2021年12月7日周二 22:27写道:
ChangeList: RFC v1:
- only upstream modeset and atomic at first commit.
- remove some unused code;
- use alpha and blend_mode properties;
- add yaml support;
- remove auto-adaptive panel driver;
- bugfix
RFC v2:
- add sprd crtc and plane module for KMS, preparing for multi crtc&encoder
- remove gem drivers, use generic CMA handlers
- remove redundant "module_init", all the sub modules loading by KMS
RFC v3:
- multi crtc&encoder design have problem, so rollback to v1
RFC v4:
- update to gcc-linaro-7.5.0
- update to Linux 5.6-rc3
- remove pm_runtime support
- add COMPILE_TEST, remove unused kconfig
- "drm_dev_put" on drm_unbind
- fix some naming convention issue
- remove semaphore lock for crtc flip
- remove static variables
RFC v5:
- optimize encoder and connector code implementation
- use "platform_get_irq" and "platform_get_resource"
- drop useless function return type, drop unless debug log
- custom properties should be separate, so drop it
- use DRM_XXX replase pr_xxx
- drop dsi&dphy hal callback ops
- drop unless callback ops checking
- add comments for sprd dpu structure
RFC v6:
- Access registers via readl/writel
- Checking for unsupported KMS properties (format, rotation, blend_mode, etc) on plane_check ops
- Remove always true checks for dpu core ops
RFC v7:
- Fix DTC unit name warnings
- Fix the problem of maintainers
- Call drmm_mode_config_init to mode config init
- Embed drm_device in sprd_drm and use devm_drm_dev_alloc
- Replace DRM_XXX with drm_xxx on KMS module, but not suitable for other subsystems
- Remove plane_update stuff, dpu handles all the HW update in crtc->atomic_flush
- Dsi&Dphy Code structure adjustment, all move to "sprd/"
v0:
- Remove dpu_core_ops stuff layer for sprd drtc driver, but dpu_layer need to keeping. Because all the HW update in crtc->atomic_flush, we need temporary storage all layers for the dpu pageflip of atomic_flush.
- Add ports subnode with port@X.
v1:
- Remove dphy and dsi graph binding, merge the dphy driver into the dsi.
- Add commit messages for Unisoc's virtual nodes.
v2:
- Use drm_xxx to replace all DRM_XXX.
- Use kzalloc to replace devm_kzalloc for sprd_dsi/sprd_dpu structure init.
- Remove dpu_core_ops midlayer.
v3:
- Remove dpu_layer midlayer and commit layers by aotmic_update
v4:
- Move the devm_drm_dev_alloc to master_ops->bind function.
- The managed drmm_mode_config_init() it is no longer necessary for drivers to explicitly call drm_mode_config_cleanup, so delete it.
- Use drmm_helpers to allocate crtc ,planes and encoder.
- Move allocate crtc ,planes, encoder to bind funtion.
- Move rotation enum definitions to crtc layer reg bitfields.
v5:
- Remove subdir-ccflgas-y for Makefile.
- Keep the selects sorted by alphabet for Kconfig.
- Fix the checkpatch warnings.
- Use mode_set_nofb instead of mode_valid callback.
- Follow the OF-Graph bindings, use of_graph_get_port_by_id instead of of_parse_phandle.
- Use zpos to represent the layer position.
- Rebase to last drm misc branch.
- Remove panel_in port for dsi node.
- Drop the dsi ip file prefix.
- Add Signed-off-by for dsi&dphy patch.
- Use the mode_flags of mipi_dsi_device to setup crtc DPI and EDPI mode.
v6:
- Disable and clear interrupts before register dpu IRQ
- Init dpi config used by crtc_state->adjusted_mode on mode_set_nofb
- Remove enable_irq and disable_irq function call.
- Remove drm_format_info function call.
- Redesign the way to access the dsi register.
- Reduce the dsi_context member variables.
v7:
- Fix codeing style issue by checkpatch.
- Drop the pll registers structure define.
- Use bridge API instead of drm panel API.
- Register mipi_dsi_host on probe phase;
- Remove iommu error interrupt handling function.
- Remove some unused function.
v8:
- Fix missing signed-off-by.
- Move component_add to dsi_host.attach callback.
Kevin Tang (6): dt-bindings: display: add Unisoc's drm master bindings drm/sprd: add Unisoc's drm kms master dt-bindings: display: add Unisoc's dpu bindings drm/sprd: add Unisoc's drm display controller driver dt-bindings: display: add Unisoc's mipi dsi controller bindings drm/sprd: add Unisoc's drm mipi dsi&dphy driver
.../display/sprd/sprd,display-subsystem.yaml | 64 + .../display/sprd/sprd,sharkl3-dpu.yaml | 77 ++ .../display/sprd/sprd,sharkl3-dsi-host.yaml | 88 ++ drivers/gpu/drm/Kconfig | 2 + drivers/gpu/drm/Makefile | 1 + drivers/gpu/drm/sprd/Kconfig | 13 + drivers/gpu/drm/sprd/Makefile | 8 + drivers/gpu/drm/sprd/megacores_pll.c | 305 +++++ drivers/gpu/drm/sprd/sprd_dpu.c | 880 ++++++++++++++ drivers/gpu/drm/sprd/sprd_dpu.h | 109 ++ drivers/gpu/drm/sprd/sprd_drm.c | 205 ++++ drivers/gpu/drm/sprd/sprd_drm.h | 19 + drivers/gpu/drm/sprd/sprd_dsi.c | 1073 +++++++++++++++++ drivers/gpu/drm/sprd/sprd_dsi.h | 126 ++ 14 files changed, 2970 insertions(+) create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,display-subsystem.yaml create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dpu.yaml create mode 100644 Documentation/devicetree/bindings/display/sprd/sprd,sharkl3-dsi-host.yaml create mode 100644 drivers/gpu/drm/sprd/Kconfig create mode 100644 drivers/gpu/drm/sprd/Makefile create mode 100644 drivers/gpu/drm/sprd/megacores_pll.c create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.c create mode 100644 drivers/gpu/drm/sprd/sprd_dpu.h create mode 100644 drivers/gpu/drm/sprd/sprd_drm.c create mode 100644 drivers/gpu/drm/sprd/sprd_drm.h create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.c create mode 100644 drivers/gpu/drm/sprd/sprd_dsi.h
-- 2.29.0