On 17.09.2014 21:35, Maarten Lankhorst wrote:
diff --git a/drivers/gpu/drm/radeon/radeon_semaphore.c b/drivers/gpu/drm/radeon/radeon_semaphore.c index 4d4b0773638a..68311da39c09 100644 --- a/drivers/gpu/drm/radeon/radeon_semaphore.c +++ b/drivers/gpu/drm/radeon/radeon_semaphore.c @@ -124,27 +124,39 @@ void radeon_semaphore_sync_fence(struct radeon_semaphore *semaphore,
- Sync to the fence using this semaphore object
*/ -void radeon_semaphore_sync_resv(struct radeon_semaphore *sema,
struct reservation_object *resv,
bool shared)
+int radeon_semaphore_sync_resv(struct radeon_device *rdev,
struct radeon_semaphore *sema,
struct reservation_object *resv,
bool shared, bool intr)
The callers of this function would be more readable if it took flags instead of the shared and intr bools.