On Thu, May 15, 2014 at 12:47:21AM +0530, Rahul Sharma wrote: [...]
diff --git a/Documentation/devicetree/bindings/phy/samsung-phy.txt b/Documentation/devicetree/bindings/phy/samsung-phy.txt
[...]
+For "samsung,exynos4210-simple-phy" compatible PHYs the second cell in +the PHY specifier identifies the PHY and the supported phys for exynos4210
I think the specifier is only the part after the phandle, so this should probably be "... compatible PHYs the single cell specifier ..." or something equivalent.
+are:
- HDMI_PHY,
- DAC_PHY,
- ADC_PHY,
- PCIE_PHY,
- SATA_PHY.
I think you need to specify the literal values here as well, since the binding must be fully self-contained. That is you can't rely on the DT binding to be bundled with the exynos-simple-phy.h header.
@@ -20,3 +20,4 @@ phy-exynos-usb2-$(CONFIG_PHY_EXYNOS4X12_USB2) += phy-exynos4x12-usb2.o phy-exynos-usb2-$(CONFIG_PHY_EXYNOS5250_USB2) += phy-exynos5250-usb2.o obj-$(CONFIG_PHY_EXYNOS5_USBDRD) += phy-exynos5-usbdrd.o obj-$(CONFIG_PHY_XGENE) += phy-xgene.o +obj-$(CONFIG_EXYNOS_SIMPLE_PHY) += exynos-simple-phy.o
Perhaps this should be named phy-exynos-simple for consistency? Also it may be a good idea to sort this alphabetically to reduce the potential for conflicts.
+static int exynos_phy_probe(struct platform_device *pdev) +{
- const struct of_device_id *of_id = of_match_device(
of_match_ptr(exynos_phy_of_match), &pdev->dev);
Why does this need of_match_ptr()?
- dev_info(dev, "probe success\n");
If at all this should be dev_dbg(). But in general the driver core will already complain if the driver fails to probe, so there's in general no need to mention when it probes successfully.
diff --git a/include/dt-bindings/phy/exynos-simple-phy.h b/include/dt-bindings/phy/exynos-simple-phy.h
[...]
+/* simeple phys */
s/simeple phys/simple PHYs/
Although on second thought that comment probably shouldn't be there in the first place.
+#define INVALID (~1)
This doesn't belong in this header. The value should never be used by a DT source file, should it?
+#define HDMI_PHY 0 +#define DAC_PHY 1 +#define ADC_PHY 2 +#define PCIE_PHY 3 +#define SATA_PHY 4
Perhaps these should be namespaced somehow to avoid potential conflicts with other PHY providers?
+#define PHY_NR 5
I'm not sure that this belongs here either. It's not a value that will ever appear in a DT source file.
Thierry