Use positive logic for better readability. This also eliminates one of_node_put() call, making the code shorter.
Signed-off-by: Baruch Siach baruch@tkos.co.il --- drivers/gpu/drm/drm_of.c | 8 +++----- 1 file changed, 3 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.c index 4c191c050e7d..fa354d14127b 100644 --- a/drivers/gpu/drm/drm_of.c +++ b/drivers/gpu/drm/drm_of.c @@ -122,12 +122,10 @@ int drm_of_component_probe(struct device *dev, if (!port) break;
- if (!of_device_is_available(port->parent)) { - of_node_put(port); - continue; - } + if (of_device_is_available(port->parent)) + drm_of_component_match_add(dev, &match, compare_of, + port);
- drm_of_component_match_add(dev, &match, compare_of, port); of_node_put(port); }