-----Original Message----- From: Doug Anderson dianders@chromium.org Sent: Friday, March 18, 2022 10:51 PM To: Sankeerth Billakanti (QUIC) quic_sbillaka@quicinc.com Cc: dri-devel dri-devel@lists.freedesktop.org; linux-arm-msm <linux-arm- msm@vger.kernel.org>; freedreno freedreno@lists.freedesktop.org; LKML linux-kernel@vger.kernel.org; open list:OPEN FIRMWARE AND FLATTENED DEVICE TREE BINDINGS devicetree@vger.kernel.org; Rob Clark robdclark@gmail.com; Sean Paul seanpaul@chromium.org; Stephen Boyd swboyd@chromium.org; quic_kalyant quic_kalyant@quicinc.com; Abhinav Kumar (QUIC) quic_abhinavk@quicinc.com; Kuogee Hsieh (QUIC) quic_khsieh@quicinc.com; Andy Gross agross@kernel.org; bjorn.andersson@linaro.org; Rob Herring robh+dt@kernel.org; krzk+dt@kernel.org; Sean Paul sean@poorly.run; David Airlie airlied@linux.ie; Daniel Vetter daniel@ffwll.ch; Thierry Reding thierry.reding@gmail.com; Sam Ravnborg sam@ravnborg.org; dmitry.baryshkov@linaro.org; quic_vproddut quic_vproddut@quicinc.com Subject: Re: [PATCH v5 2/9] arm64: dts: qcom: sc7280: Add support for eDP panel on CRD
Hi,
On Wed, Mar 16, 2022 at 10:36 AM Sankeerth Billakanti quic_sbillaka@quicinc.com wrote:
Enable support for eDP interface via aux_bus on CRD platform.
Signed-off-by: Sankeerth Billakanti quic_sbillaka@quicinc.com
Changes in v5:
- Change the order of patches
- Remove the backlight nodes
- Remove the bias setting
- Fix compilation issue
- Model VREG_EDP_BP for backlight power
Changes in v4:
- Create new patch for name changes
- Remove output-low
Changes in v3:
- Sort the nodes alphabetically
- Use - instead of _ as node names
- Place the backlight and panel nodes under root
- Change the name of edp_out to mdss_edp_out
- Change the names of regulator nodes
- Delete unused properties in the board file
Changes in v2:
- Sort node references alphabetically
- Improve readability
- Move the pwm pinctrl to pwm node
- Move the regulators to root
- Define backlight power
- Remove dummy regulator node
- Cleanup pinctrl definitions
arch/arm64/boot/dts/qcom/sc7280-crd.dts | 93 +++++++++++++++++++++++++++++++++ 1 file changed, 93 insertions(+)
At a high level, I'd expect your patch to be based upon Matthias's series, AKA the 4 patches from:
https://lore.kernel.org/r/20220316172814.v1.1.I2deda8f2cd6adfbb525a97d8f ee008a8477b7b0e@changeid/
I'll leave it up to you about whether you care to support eDP on the old CRD1/2 or just on CRD3. Personally I'd think CRD3 would be enough.
Then, I'd expect your patch to mostly incorporate https://crrev.com/c/3379844, though that patch was written before aux- bus support so the panel would need to go in a different place.
Stephen already gave some comments and basing on Matthias's patches will be a pretty big change, so I probably won't comment lots more.
I rebased my change on top of Matthias's changes now. We are discussing about the qcard changes internally to understand the way ahead. I believe all my current changes are localized to the crd-r3 files only for the qyalcomm crd3.1
I want to have a different series for c and dt changes to expedite review process. May I separate the c changes from this series?
+&mdss_edp {
status = "okay";
data-lanes = <0 1 2 3>;
vdda-1p2-supply = <&vreg_l6b_1p2>;
vdda-0p9-supply = <&vreg_l10c_0p8>;
aux-bus {
edp_panel: edp-panel {
As Stephen pointed out, it should be called "panel".
Okay. Will make that change