On 04/15/2014 03:42 PM, Rahul Sharma wrote:
On 15 April 2014 18:41, Tomasz Stanislawski t.stanislaws@samsung.com wrote:
On 04/15/2014 11:42 AM, Rahul Sharma wrote:
Hi Tomasz,
On 15 April 2014 14:57, Tomasz Stanislawski t.stanislaws@samsung.com wrote:
Adds support for limitation of maximal pixel clock of HDMI signal. This feature is needed on boards that contains lines or bridges with frequency limitations.
Signed-off-by: Tomasz Stanislawski t.stanislaws@samsung.com
[snip]
diff --git a/include/media/s5p_hdmi.h b/include/media/s5p_hdmi.h index 181642b..7272d65 100644 --- a/include/media/s5p_hdmi.h +++ b/include/media/s5p_hdmi.h @@ -31,6 +31,7 @@ struct s5p_hdmi_platform_data { int mhl_bus; struct i2c_board_info *mhl_info; int hpd_gpio;
u32 max_pixel_clock;
};
We have already removed Non DT support from the drm hdmi driver. IMO we should not be extending the pdata struct.
Regards, Rahul Sharma
Hi Rahul,
This is not a non-DT patch. The s5p_hdmi_platform_data is generated from DT itself. This structure is just a parsed version of DT attributes.
It may be a good idea to rename s5p_hdmi_platform_data to exynos_hdmi_pdata and move it to exynos_hdmi_drm.c file or parse DT directly in probe function.
I can prepare a patch for that.
Else we can completely remove the dependency from s5p_hdmi_platform_data. We can directly assign to hdmi context variables. Later we can remove that struct itself from include/. What you say?
This structure cannot be removed from include yet because it is used by s5p-tv driver. However its usage can be removed from both drivers. I can prepare both.
Regards, Rahul Sharma
Regards, Tomasz Stanislawski
Regards, Tomasz Stanislawski
#endif /* S5P_HDMI_H */
1.7.9.5
dri-devel mailing list dri-devel@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/dri-devel