On Fri, Apr 3, 2020 at 6:58 AM Daniel Vetter daniel.vetter@ffwll.ch wrote:
We already have it in v3d_dev->drm.dev with zero additional pointer chasing. Personally I don't like duplicated pointers like this because:
- reviewers need to check whether the pointer is for the same or
different objects if there's multiple
- compilers have an easier time too
To avoid having to pull in some big headers I implemented the casting function as a macro instead of a static inline. Typechecking thanks to container_of still assured.
But also a bit a bikeshed, so feel free to ignore.
Signed-off-by: Daniel Vetter daniel.vetter@intel.com Cc: Eric Anholt <eric@anholt.net
Acked-by: Eric Anholt eric@anholt.net