On Thu, Jul 12, 2018 at 09:51:33AM -0400, Sean Paul wrote:
On Mon, Jul 09, 2018 at 10:40:16AM +0200, Daniel Vetter wrote:
This is starting to become easy!
Note: This needs the patch to move for_each_if from drmP.h to kernel.h or it won't compile.
Signed-off-by: Daniel Vetter daniel.vetter@intel.com
Once for_each_if gets sorted out (however it goes).
Yeah I've left those out for now, will deal with that bikeshed when I'm back from vacations.
Reviewed-by: Sean Paul seanpaul@chromium.org
Thanks a lot for your review, everything except the drmP.h shuffling patches merged.
Cheers, Daniel
drivers/gpu/drm/drm_crtc.c | 5 ++++- 1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c index a6906c4ab880..30f93e460f4e 100644 --- a/drivers/gpu/drm/drm_crtc.c +++ b/drivers/gpu/drm/drm_crtc.c @@ -34,7 +34,7 @@ #include <linux/slab.h> #include <linux/export.h> #include <linux/dma-fence.h> -#include <drm/drmP.h> +#include <linux/uaccess.h> #include <drm/drm_crtc.h> #include <drm/drm_edid.h> #include <drm/drm_fourcc.h> @@ -42,6 +42,9 @@ #include <drm/drm_atomic.h> #include <drm/drm_auth.h> #include <drm/drm_debugfs_crc.h> +#include <drm/drm_drv.h> +#include <drm/drm_print.h> +#include <drm/drm_file.h>
#include "drm_crtc_internal.h"
#include "drm_internal.h"
2.18.0
dri-devel mailing list dri-devel@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/dri-devel
-- Sean Paul, Software Engineer, Google / Chromium OS