On 4/12/22 09:31, Geert Uytterhoeven wrote:
[snip]
t->spi = spi;
t->dc = ssd130x_spi_get_dc(&spi->dev);
if (IS_ERR(t->dc))
return PTR_ERR(t->dc);
This can be simplified (no need for the PTR_ERR(ERR_PTR(...) dance) by open-coding ssd130x_spi_get_dc() here.
Right, that will be better indeed.