On Mon, Dec 4, 2017 at 4:20 PM, Gustavo A. R. Silva garsilva@embeddedor.com wrote:
Hi Joonas,
Quoting Joonas Lahtinen joonas.lahtinen@linux.intel.com:
On Mon, 2017-11-27 at 16:17 -0600, Gustavo A. R. Silva wrote:
In preparation to enabling -Wimplicit-fallthrough, mark switch cases where we are expecting to fall through.
I have to say I'm totally not sold on regexps matching comment contents. Was something more explicit ever considered? Like:
#define FALLTHROUGH __attribute__((fallthrough));
With the appropriate version checks, of course.
One of the arguments is that comments lets us leverage the existing static analyzers.
We've been discussing this during the last week, feel free to join the discussion:
http://www.spinics.net/lists/kernel/msg2659908.html http://www.spinics.net/lists/kernel/msg2659906.html
If we go with existing rules, then either pls patch coding style, or be a bit more liberal in what you accept. E.g. fallthrough vs fall through seems a bit a bikeshed (and will be an endless source of work for you).
I'd also claim that "this shouldn't happen, dump a backtrace and hope for the best" style macros like i915's MISSING_CASE or WARN_ON (as the only thing) should count as an auto-fallthrough annotation.
From a quick look, that would cover everything in your patch.
-Daniel
Thanks!
Gustavo A. R. Silva
Intel-gfx mailing list Intel-gfx@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/intel-gfx