On Thu, Aug 04, 2016 at 09:32:01AM +0200, David Herrmann wrote:
Hi
On Wed, Aug 3, 2016 at 9:11 PM, Daniel Vetter daniel.vetter@ffwll.ch wrote:
It's super confusing that new drivers need to be marked with DRIVER_MODESET when really it means DRIVER_MODERN. Much better to invert the meaning and rename it to something that's suitably off-putting.
Since there's over 100 places using DRIVER_MODESET we need to roll out this change without a flag day.
v2: Update docs.
Signed-off-by: Daniel Vetter daniel.vetter@intel.com
Documentation/gpu/drm-internals.rst | 9 ++++++--- drivers/gpu/drm/i810/i810_drv.c | 4 +--- drivers/gpu/drm/mga/mga_drv.c | 2 +- drivers/gpu/drm/r128/r128_drv.c | 2 +- drivers/gpu/drm/savage/savage_drv.c | 2 +- drivers/gpu/drm/sis/sis_drv.c | 2 +- drivers/gpu/drm/tdfx/tdfx_drv.c | 1 + drivers/gpu/drm/via/via_drv.c | 2 +- include/drm/drmP.h | 1 + 9 files changed, 14 insertions(+), 11 deletions(-)
Reviewed-by: David Herrmann dh.herrmann@gmail.com
Also, how about this:
config DRM_LEGACY bool "Enable legacy drivers (DANGEROUS)" depends on DRM depends on BROKEN help ...
Then everyone else gets depends on DRM_LEGACY. The benefit is that we get the chance to add a useful help message and hopefully explains the situation more cleary to devs. -Chris