On Mon, 2017-05-01 at 18:46 +0200, SF Markus Elfring wrote:
From: Markus Elfring elfring@users.sourceforge.net Date: Mon, 1 May 2017 17:08:56 +0200
A few single characters (line breaks) should be put into a sequence. Thus use the corresponding function "seq_putc".
This issue was detected by using the Coccinelle software.
[]
diff --git a/drivers/gpu/drm/drm_dp_mst_topology.c b/drivers/gpu/drm/drm_dp_mst_topology.c
[]
@@ -2840,17 +2840,17 @@ void drm_dp_mst_dump_topology(struct seq_file *m, seq_printf(m, "dpcd: "); for (i = 0; i < DP_RECEIVER_CAP_SIZE; i++) seq_printf(m, "%02x ", buf[i]);
seq_printf(m, "\n");
ret = drm_dp_dpcd_read(mgr->aux, DP_FAUX_CAP, buf, 2); seq_printf(m, "faux/mst: "); for (i = 0; i < 2; i++) seq_printf(m, "%02x ", buf[i]);seq_putc(m, '\n');
seq_printf(m, "\n");
ret = drm_dp_dpcd_read(mgr->aux, DP_MSTM_CTRL, buf, 1); seq_printf(m, "mst ctrl: "); for (i = 0; i < 1; i++) seq_printf(m, "%02x ", buf[i]);seq_putc(m, '\n');
seq_printf(m, "\n");
seq_putc(m, '\n');
Please don't be _just_ mechanical.
Stop and read the code the tools you use using suggest modifying and see how you can improve it for a human reader.
If you're really trying to improve these to make them more readable or smaller object code size, you should use the vsprintf extensions like:
seq_printf(m, "dpcd: %*ph\n", DP_RECEIVER_CAP_SIZE, buf);
And if these are supposed to be correct, then the return value from drm_dp_dpcd_read should be tested too.
Likely these repeated code blocks could be put into a helper function.