Hi Marek, I read the patch once more.
On Mon, Apr 18, 2022 at 04:51:04PM +0200, Marek Vasut wrote:
The i.MX8MP contains two syscon registers which are responsible
Here it says i.MX8MP
for configuring the on-SoC DPI-to-LVDS serializer. Add DT binding which represents this serializer as a bridge.
Signed-off-by: Marek Vasut marex@denx.de Cc: Laurent Pinchart laurent.pinchart@ideasonboard.com Cc: Lucas Stach l.stach@pengutronix.de Cc: Maxime Ripard maxime@cerno.tech Cc: Peng Fan peng.fan@nxp.com Cc: Rob Herring robh+dt@kernel.org Cc: Robby Cai robby.cai@nxp.com Cc: Robert Foss robert.foss@linaro.org Cc: Sam Ravnborg sam@ravnborg.org Cc: Thomas Zimmermann tzimmermann@suse.de Cc: devicetree@vger.kernel.org To: dri-devel@lists.freedesktop.org
V2: - Consistently use fsl,imx8mp-ldb as compatible - Drop items: from compatible: - Replace minItems with maxItems in clocks: - Drop quotes from clock-names const: ldb - Rename syscon to fsl,syscon - Use generic name of ldb-lvds in example
.../bindings/display/bridge/nxp,ldb.yaml | 96 +++++++++++++++++++ 1 file changed, 96 insertions(+) create mode 100644 Documentation/devicetree/bindings/display/bridge/nxp,ldb.yaml
diff --git a/Documentation/devicetree/bindings/display/bridge/nxp,ldb.yaml b/Documentation/devicetree/bindings/display/bridge/nxp,ldb.yaml new file mode 100644 index 0000000000000..f3182566eb316 --- /dev/null +++ b/Documentation/devicetree/bindings/display/bridge/nxp,ldb.yaml @@ -0,0 +1,96 @@ +# SPDX-License-Identifier: (GPL-2.0-only OR BSD-2-Clause) +%YAML 1.2 +--- +$id: http://devicetree.org/schemas/display/bridge/nxp,ldb.yaml# +$schema: http://devicetree.org/meta-schemas/core.yaml#
+title: NXP i.MX8M DPI to LVDS bridge chip
Here it says i.MX8M
+maintainers:
- Marek Vasut marex@denx.de
+description: |
- The i.MX8MP contains two syscon registers which are responsible
Here it says i.MX8MP
- for configuring the on-SoC DPI-to-LVDS serializer. This describes
- those registers as bridge within the DT.
+properties:
- compatible:
- const: fsl,imx8mp-ldb
Here it says fsl,imx8mp
It looks a little inconsistent, I guess the title needs a fix. a-b stands with the title fixed.
Sam
- clocks:
- maxItems: 1
- clock-names:
- const: ldb
- fsl,syscon:
- $ref: /schemas/types.yaml#/definitions/phandle
- description: A phandle to media block controller.
- ports:
- $ref: /schemas/graph.yaml#/properties/ports
- properties:
port@0:
$ref: /schemas/graph.yaml#/properties/port
description: Video port for DPI input.
port@1:
$ref: /schemas/graph.yaml#/properties/port
description: Video port for LVDS Channel-A output (panel or bridge).
port@2:
$ref: /schemas/graph.yaml#/properties/port
description: Video port for LVDS Channel-B output (panel or bridge).
- required:
- port@0
- port@1
+required:
- compatible
- clocks
- fsl,syscon
- ports
+additionalProperties: false
+examples:
- |
- #include <dt-bindings/clock/imx8mp-clock.h>
- bridge {
compatible = "fsl,imx8mp-ldb";
clocks = <&clk IMX8MP_CLK_MEDIA_LDB>;
clock-names = "ldb";
fsl,syscon = <&media_blk_ctrl>;
ports {
#address-cells = <1>;
#size-cells = <0>;
port@0 {
reg = <0>;
ldb_from_lcdif2: endpoint {
remote-endpoint = <&lcdif2_to_ldb>;
};
};
port@1 {
reg = <1>;
ldb_lvds_ch0: endpoint {
remote-endpoint = <&ldb_to_lvdsx4panel>;
};
};
port@2 {
reg = <2>;
ldb_lvds_ch1: endpoint {
};
};
};
- };
-- 2.35.1