On Wed, Nov 14, 2012 at 01:49:44PM +0100, Thierry Reding wrote:
On Wed, Nov 14, 2012 at 12:43:22PM +0100, Steffen Trumtrar wrote: [...]
diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c
[...]
@@ -504,6 +505,41 @@ drm_gtf_mode(struct drm_device *dev, int hdisplay, int vdisplay, int vrefresh, } EXPORT_SYMBOL(drm_gtf_mode);
+#if IS_ENABLED(CONFIG_VIDEOMODE) +int display_mode_from_videomode(struct videomode *vm, struct drm_display_mode *dmode)
Given that this is still a DRM core function, maybe it should get a drm_ prefix? Also the line is too long, so you may want to wrap the argument list.
Thierry
Yes, seems to fit better to the rest of the file.
Regards, Steffen