Il 19/11/21 14:19, Robert Foss ha scritto:
Hey Angelo,
On Wed, 10 Nov 2021 at 13:46, AngeloGioacchino Del Regno angelogioacchino.delregno@collabora.com wrote:
Il 10/11/21 13:44, Dafna Hirschfeld ha scritto:
On 02.11.21 11:36, AngeloGioacchino Del Regno wrote:
In preparation for varying the poweron error handling in function ps8640_bridge_poweron(), move function ps8640_bridge_poweroff() up and also move the actual logic to power off the chip to a new __ps8640_bridge_poweroff() function.
Signed-off-by: AngeloGioacchino Del Regno angelogioacchino.delregno@collabora.com
drivers/gpu/drm/bridge/parade-ps8640.c | 37 ++++++++++++++------------ 1 file changed, 20 insertions(+), 17 deletions(-)
diff --git a/drivers/gpu/drm/bridge/parade-ps8640.c b/drivers/gpu/drm/bridge/parade-ps8640.c index 8c5402947b3c..41f5d511d516 100644 --- a/drivers/gpu/drm/bridge/parade-ps8640.c +++ b/drivers/gpu/drm/bridge/parade-ps8640.c @@ -293,6 +293,26 @@ static int ps8640_bridge_vdo_control(struct ps8640 *ps_bridge, return 0; } +static void __ps8640_bridge_poweroff(struct ps8640 *ps_bridge) +{
- gpiod_set_value(ps_bridge->gpio_reset, 1);
- gpiod_set_value(ps_bridge->gpio_powerdown, 1);
- if (regulator_bulk_disable(ARRAY_SIZE(ps_bridge->supplies),
ps_bridge->supplies)) {
DRM_ERROR("cannot disable regulators\n");
- }
That '{' is redundant
Thanks, Danfa
Hi Dafna, the braces were added as a way to increase human readability.
Not to bikeshed this, but the kernel style guide is clear about this. No unneeded braces should be used where a single statement will do.
Hey Robert!
That's right, style rules come before personal preferences. I'll send a v3 without the braces as soon as possible!
Cheers, - Angelo