On 9/28/21 1:58 PM, Borislav Petkov wrote:
On Tue, Sep 28, 2021 at 01:48:46PM -0700, Kuppuswamy, Sathyanarayanan wrote:
Just read it. If you want to use cpuid_has_tdx_guest() directly in cc_platform_has(), then you want to rename intel_cc_platform_has() to tdx_cc_platform_has()?
Why?
You simply do:
if (cpuid_has_tdx_guest()) intel_cc_platform_has(...);
and lemme paste from that mail: " ...you should use cpuid_has_tdx_guest() instead but cache its result so that you don't call CPUID each time the kernel executes cc_platform_has()."
Makes sense?
Yes. But, since the check is related to TDX, I just want to confirm whether you are fine with naming the function as intel_*().
Since this patch is going to have dependency on TDX code, I will include this patch in TDX patch set.