On Mon, Jul 9, 2018 at 12:36 PM, Peter Zijlstra peterz@infradead.org wrote:
On Mon, Jul 09, 2018 at 10:36:49AM +0200, Daniel Vetter wrote:
Avoids complaints from gcc about ambiguous else clauses.
Is that a new thing? I'm fairly sure I've never seen it do that,
Signed-off-by: Daniel Vetter daniel.vetter@intel.com Cc: Andrew Morton akpm@linux-foundation.org Cc: Peter Zijlstra peterz@infradead.org
include/linux/topology.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/include/linux/topology.h b/include/linux/topology.h index cb0775e1ee4b..4fba5a5b148d 100644 --- a/include/linux/topology.h +++ b/include/linux/topology.h @@ -40,7 +40,7 @@
#define for_each_node_with_cpus(node) \ for_each_online_node(node) \
if (nr_cpus_node(node))
for_each_if (nr_cpus_node(node))
Not having gotten any of the other patches, I'm not really sure what this does and such, but improve readability it does not :/
Patch 1 in this series, which I dumped onto lkml as a whole:
https://lkml.org/lkml/2018/7/9/179
Imo it does improve readability for the if (!cond) {} else pattern. And (assuming my grep fu isn't too badly wrong) most places in the kernel do use this pattern in for_each macros, so I guess its a real thing. We've definitely hit it plenty in drm iterators (but we seem to like if() checks in iterator macros maybe a bit too much).
I'm happy to drop this patch tough if you deem it offensive. -Daniel