On 2/13/20 10:59 AM, Dietmar Eggemann wrote:
On 06/02/2020 14:46, lukasz.luba@arm.com wrote:
From: Lukasz Luba lukasz.luba@arm.com
[..]
@@ -26,7 +28,7 @@ framework, and interested clients reading the data from it::
s/::/: ?
| Thermal (IPA) | | Scheduler (EAS) | | Other | +---------------+ +-----------------+ +---------------+ | | em_pd_energy() |
| | em_cpu_get() |
| em_get_pd() | em_cpu_get() | +---------+ | +---------+
em_get_pd() and em_cpu_get()? Why not em_pd_get()? em_cpu_get() is a specific em_get_pd(). right?
Yes. I will rename 'em_get_pd' to 'em_pd_get'
[...]
@@ -85,13 +89,20 @@ API. 2.3 Accessing performance domains ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
+There is two API functions which provide the access to the energy model: +em_cpu_get() which takes CPU id as an argument and em_get_pd() with device +pointer as an argument. It depends on the subsystem which interface it is +going to use, but in case of CPU devices both functions return the same +performance domain.
There is probably a reason why we need this specific function for CPU devices? The reason should be described. People might ask why em_get_pd() is not sufficient.
True, good point. I will extend the comment in em_cpu_get().
[...]
- A "performance domain" represents a group of CPUs whose performance is
- scaled together. All CPUs of a performance domain must have the same
- micro-architecture. Performance domains often have a 1-to-1 mapping with
- CPUFreq policies.
- In case of CPU device, a "performance domain" represents a group of CPUs
- whose performance is scaled together. All CPUs of a performance domain
- must have the same micro-architecture. Performance domains often have
- a 1-to-1 mapping with CPUFreq policies.
*/ struct em_perf_domain {
- In case of other devices the 'priv' field is unused.
- struct em_cap_state *table;
- int nr_cap_states;
- unsigned long cpus[0];
- struct em_perf_state *table;
- int nr_perf_states;
- void *priv;
In case you go back to the variable length field plus type field to distingush EM devices, keep cpus[0] as the name.
OK, I will.
[..]
/**
- em_pd_energy() - Estimates the energy consumed by the CPUs of a perf. domain
- em_pd_energy() - Estimates the energy consumed by the CPUs of a perf.
domain
Why this change?
hmmm, that's odd, maybe there was 'device' then I changed it back to 'CPUs' but forgot to move the 'domain' to the old place.
[...]
@@ -141,12 +210,12 @@ static struct em_perf_domain *em_create_pd(cpumask_t *span, int nr_states, */ opp_eff = freq / power; if (opp_eff >= prev_opp_eff)
pr_warn("pd%d: hertz/watts ratio non-monotonically decreasing: em_cap_state %d >= em_cap_state%d\n",
cpu, i, i - 1);
dev_warn(dev, "energy_model: hertz/watts ratio non-monotonically decreasing: em_perf_state %d >= em_perf_state%d\n",
s/energy_model/EM ?
OK, I will rename them in all places.
Thank you for the review.
Regards, Lukasz