Excerpts from Marc Zyngier's message of June 24, 2021 8:06 pm:
On Thu, 24 Jun 2021 09:58:00 +0100, Nicholas Piggin npiggin@gmail.com wrote:
Excerpts from David Stevens's message of June 24, 2021 1:57 pm:
From: David Stevens stevensd@chromium.org out_unlock: if (is_tdp_mmu_root(vcpu->kvm, vcpu->arch.mmu->root_hpa)) read_unlock(&vcpu->kvm->mmu_lock); else write_unlock(&vcpu->kvm->mmu_lock);
- kvm_release_pfn_clean(pfn);
- if (pfnpg.page)
return r;put_page(pfnpg.page);
}
How about
kvm_release_pfn_page_clean(pfnpg);
I'm not sure. I always found kvm_release_pfn_clean() ugly, because it doesn't mark the page 'clean'. I find put_page() more correct.
Something like 'kvm_put_pfn_page()' would make more sense, but I'm so bad at naming things that I could just as well call it 'bob()'.
That seems like a fine name to me. A little better than bob.
Thanks, Nick