On Wed, Jul 15, 2015 at 06:39:26PM +0530, Kausal Malladi wrote: [...]
diff --git a/include/drm/drm_crtc.h b/include/drm/drm_crtc.h index 57ca8cc..408d39a 100644 --- a/include/drm/drm_crtc.h +++ b/include/drm/drm_crtc.h @@ -1178,6 +1178,12 @@ struct drm_mode_config { struct drm_property *suggested_x_property; struct drm_property *suggested_y_property;
- /* Color Management Properties */
- struct drm_property *prop_color_capabilities;
- struct drm_property *prop_palette_before_ctm;
- struct drm_property *prop_palette_after_ctm;
- struct drm_property *prop_ctm;
All existing properties are named *_property, and it'd be good to keep things consistent by following that scheme. Perhaps they could have a common prefix (cm_?) to group them?
Thierry