On Sun, Nov 3, 2013 at 12:43 PM, David Herrmann dh.herrmann@gmail.com wrote:
Wrt patch 2 I don't see the point - better to just outright kill this callback and inline it like the agp_init one.
2/2 just does a rename. Where do you want to inline it? In drm_pci_exit()? It calls drm_put_dev() which already does a kfree() so we cannot call anything after it. And we cannot call anything before it as ->unload() is called from drm_put_dev().
We could replace drm_put_dev() with: drm_dev_unregister() drm_pci_agp_destroy() drm_dev_free() Or what did you have in mind?
For now just inline it and make it stick out really badly. Long-term we need to unbundle the teardown sequence. But imo doing that before we've sorted out all the lifetime stuff is no much use. And the lifetime rework needs a reworked init sequence first imo, or at least for end users we care much more about solid loading than solid unloading (there's udl ofc, but meh ...). -Daniel