On Thu, Jul 11, 2013 at 11:56:32AM +0200, David Herrmann wrote:
drm_gem_object_init() and drm_gem_private_object_init() do exactly the same (except for shmem alloc) so make the first use the latter to reduce code duplication.
Also drop the return code from drm_gem_private_object_init(). It seems unlikely that we will extend it any time soon so no reason to keep it around. This simplifies code paths in drivers, too.
Last but not least, fix gma500 to call drm_gem_object_release() before freeing objects that were allocated via drm_gem_private_object_init(). That isn't actually necessary for now, but might be in the future.
Cc: Patrik Jakobsson patrik.r.jakobsson@gmail.com Signed-off-by: David Herrmann dh.herrmann@gmail.com
You should also CC any driver maintainers that the patch touches. They should be acking it at the very least. -Chris