On Mon, Dec 1, 2014 at 4:56 PM, Jilai Wang jilaiw@codeaurora.org wrote:
/* Enable HDCP Encryption */
hdmi_write(hdmi, REG_HDMI_HDCP_CTRL, BIT(0) | BIT(8));
btw, as Bjron mentioned, there are a lot of these open coded BIT(n).. but from a quick check, the first two or three I looked at, we already have the appropriate defines in the rnndb generated headers, to instead do:
/* Enable HDCP Encryption */ hdmi_write(hdmi, REG_HDMI_HDCP_CTRL, HDMI_HDCP_CTRL_ENABLE | HDMI_HDCP_CTRL_ENCRYPTION_ENABLE);
that seems somewhat more readable to me ;-)
BR, -R