On Wed, Oct 31, 2012 at 10:28:02AM +0100, Steffen Trumtrar wrote: [...]
diff --git a/Documentation/devicetree/bindings/video/display-timings.txt b/Documentation/devicetree/bindings/video/display-timings.txt
[...]
@@ -0,0 +1,139 @@ +display-timings bindings +==================
+display-timings-node +------------
Maybe extend the underline to the length of the section and subsection titles respectively?
+struct display_timing +===================
Same here.
+config OF_DISPLAY_TIMINGS
- def_bool y
- depends on DISPLAY_TIMING
Maybe this should be called OF_DISPLAY_TIMING to match DISPLAY_TIMING, or rename DISPLAY_TIMING to DISPLAY_TIMINGS for the sake of consistency?
+/**
- of_get_display_timing_list - parse all display_timing entries from a device_node
- @np: device_node with the subnodes
- **/
+struct display_timings *of_get_display_timing_list(struct device_node *np)
Perhaps this would better be named of_get_display_timings() to match the return type?
- disp = kzalloc(sizeof(*disp), GFP_KERNEL);
Shouldn't you be checking this for allocation failures?
- disp->timings = kzalloc(sizeof(struct display_timing *)*disp->num_timings,
GFP_KERNEL);
Same here.
Thierry