Hi Dave,
A few fixes to the two pull requests you merged for 4.2:
- Make the reset wavefronts action be per process per device instead of per process, because one device can be stuck but the other one won't be
- Add some missing properties to the CZ device_info structure
- Rename symbols to not have CONFIG_ prefix
- Some more cleanups and debug prints
Thanks,
Oded
The following changes since commit ae45577324d1f749c907840247d443696ac3bc7a:
virtgpu: include linux/types.h to avoid warning. (2015-06-05 12:31:12 +1000)
are available in the git repository at:
git://people.freedesktop.org/~gabbayo/linux tags/drm-amdkfd-next-fixes-2015-06-10
for you to fetch changes up to da73b9fb56c14c6d537738e891906006a7960535:
drm/amdkfd: remove not used defines from cik_regs.h (2015-06-06 22:26:47 +0300)
---------------------------------------------------------------- Ben Goz (1): drm/amdkfd: make reset wavefronts per process per device
Oded Gabbay (3): drm/amdkfd: add debug print to kfd_events.c drm/amdkfd: Add missing properties to CZ device info drm/amdkfd: remove not used defines from cik_regs.h
Valentin Rothberg (1): drm/amdkfd: avoid CONFIG_ prefix for non-Kconfig symbols
drivers/gpu/drm/amd/amdkfd/cik_regs.h | 177 ++------------------- drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.c | 10 +- drivers/gpu/drm/amd/amdkfd/kfd_dbgdev.h | 6 +- drivers/gpu/drm/amd/amdkfd/kfd_device.c | 3 + .../gpu/drm/amd/amdkfd/kfd_device_queue_manager.c | 7 +- drivers/gpu/drm/amd/amdkfd/kfd_events.c | 4 + drivers/gpu/drm/amd/amdkfd/kfd_priv.h | 10 +- drivers/gpu/drm/amd/amdkfd/kfd_process.c | 21 ++- 8 files changed, 53 insertions(+), 185 deletions(-)