Hi Tobias,
2015-03-27 Tobias Jakobi tjakobi@math.uni-bielefeld.de:
Hello!
Gustavo Padovan wrote:
I would keep calling these two vars x_ratio and y_ratio. I don't see a reason to change the name here.
Right, I'm going to change this. Also I was thinking of basing the patch on your latest cleanup series (the 'drm/exynos: remove struct *_win_data abstraction on planes' one).
If you can rebase this in on top of my series this would be really good.
Then it would just be: static int mixer_setup_scale(const struct exynos_drm_plane *plane, unsigned int *x_ratio, unsigned int *y_ratio)
Also that would automatically fix your other comment below [*].
Use EPERM or ENOTSUPP. Or even true/false.
Will do!
You need to fix style here
if (mixer_setup_scale(win_data->src_width, win_data->src_height, win_data->crtc_width, win_data->crtc_height, &x_ratio, &y_ratio)) return;
With [*] this would just be: if (mixer_setup_scale(plane, &x_ratio, &y_ratio)) return;
What do you think?
Changes sounds good to me. Please go ahead and send a new patch. :)
Gustavo