On Tue, Aug 24, 2021 at 12:27 PM Alyssa Rosenzweig alyssa.rosenzweig@collabora.com wrote:
Use upper_32_bits/lower_32_bits helpers instead of open-coding them. This is easier to scan quickly compared to bitwise manipulation, and it is pleasingly symmetric. I noticed this when debugging lock_region, which had a particularly "creative" way of writing upper_32_bits.
Signed-off-by: Alyssa Rosenzweig alyssa.rosenzweig@collabora.com
drivers/gpu/drm/panfrost/panfrost_job.c | 8 ++++---- drivers/gpu/drm/panfrost/panfrost_mmu.c | 12 ++++++------ 2 files changed, 10 insertions(+), 10 deletions(-)
Reviewed-by: Rob Herring robh@kernel.org