On 07/07/2019 21:19, Laurent Pinchart wrote:
Bring the omapdss-specific .read_edid() operation in sync with the drm_bridge .get_edid() operation to ease code reuse.
Signed-off-by: Laurent Pinchart laurent.pinchart@ideasonboard.com
drivers/gpu/drm/omapdrm/dss/hdmi4.c | 34 ++++++++++++++++-------- drivers/gpu/drm/omapdrm/dss/hdmi5.c | 22 ++++++++++----- drivers/gpu/drm/omapdrm/dss/omapdss.h | 2 +- drivers/gpu/drm/omapdrm/omap_connector.c | 12 +++------ 4 files changed, 43 insertions(+), 27 deletions(-)
diff --git a/drivers/gpu/drm/omapdrm/dss/hdmi4.c b/drivers/gpu/drm/omapdrm/dss/hdmi4.c index 0a0bda7f686f..f0586108b41e 100644 --- a/drivers/gpu/drm/omapdrm/dss/hdmi4.c +++ b/drivers/gpu/drm/omapdrm/dss/hdmi4.c @@ -416,31 +416,43 @@ static void hdmi_disconnect(struct omap_dss_device *src, omapdss_device_disconnect(dst, dst->next); }
-static int hdmi_read_edid(struct omap_dss_device *dssdev,
u8 *edid, int len)
+static struct edid *hdmi_read_edid(struct omap_dss_device *dssdev) { struct omap_hdmi *hdmi = dssdev_to_hdmi(dssdev); bool need_enable;
u8 *edid; int r;
edid = kzalloc(512, GFP_KERNEL);
512 bytes is enough for everyone? =)
Maybe still keep it as a define for clarity?
Reviewed-by: Tomi Valkeinen tomi.valkeinen@ti.com
Tomi