On Thu, Feb 27, 2014 at 03:24:08PM -0800, Matt Roper wrote:
On Thu, Feb 27, 2014 at 05:39:00PM -0500, Rob Clark wrote:
On Thu, Feb 27, 2014 at 5:14 PM, Matt Roper matthew.d.roper@intel.com wrote:
Add a plane type property to allow userspace to distinguish sprite/overlay planes from primary planes. In the future we may extend this to cover cursor planes as well.
Signed-off-by: Matt Roper matthew.d.roper@intel.com
drivers/gpu/drm/drm_crtc.c | 32 ++++++++++++++++++++++++++++++++ include/drm/drm_crtc.h | 1 + include/uapi/drm/drm_mode.h | 3 +++ 3 files changed, 36 insertions(+)
diff --git a/drivers/gpu/drm/drm_crtc.c b/drivers/gpu/drm/drm_crtc.c index 21c6d4b..1032eaf 100644 --- a/drivers/gpu/drm/drm_crtc.c +++ b/drivers/gpu/drm/drm_crtc.c @@ -114,6 +114,14 @@ static const struct drm_prop_enum_list drm_dpms_enum_list[] =
DRM_ENUM_NAME_FN(drm_get_dpms_name, drm_dpms_enum_list)
+static const struct drm_prop_enum_list drm_plane_type_enum_list[] = +{
{ DRM_MODE_PLANE_TYPE_SPRITE, "Sprite" },
I'm not the *hugest* fan of using the name "sprite".. at least that too me implies sort of a subset of possible functionality of a plane..
Any suggestions on a better name? Maybe call them "traditional" planes and then just give new names to the other types (primary, cursor) that we wind up exposing when appropriate client caps are set?
What about "secondary" for any plane exposed which doesn't match one of the special-purpose planes for backwards compat? We'd then have "primary" (fixed to a crtc and used for legacy setCrtc/pageflips), "cursor" (again fixed to a crtc for use by the legacy setcurso ioctl) and a pile of secondary planes without special meaning attached to them. -Daniel