Am 18.07.19 um 18:15 schrieb Sam Ravnborg:
drm_file used drm_magic_t from uapi/drm/drm.h. This is a simple unsigned int. Just opencode it as such to break the dependency from this header file to uapi.
Mhm, why do you want to remove UAPI dependency here in the first place?
I mean the type can't change because it is UAPI, but it is rather bad for a documentation point of view.
Christian.
Signed-off-by: Sam Ravnborg sam@ravnborg.org Suggested-by: Daniel Vetter daniel.vetter@ffwll.ch Cc: Sean Paul seanpaul@chromium.org Cc: Liviu Dudau Liviu.Dudau@arm.com Cc: Chris Wilson chris@chris-wilson.co.uk Cc: Maarten Lankhorst maarten.lankhorst@linux.intel.com Cc: Maxime Ripard maxime.ripard@bootlin.com Cc: David Airlie airlied@linux.ie Cc: Daniel Vetter daniel@ffwll.ch Cc: Jani Nikula jani.nikula@intel.com Cc: Eric Anholt eric@anholt.net
include/drm/drm_file.h | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-)
diff --git a/include/drm/drm_file.h b/include/drm/drm_file.h index 67af60bb527a..046cd1bf91eb 100644 --- a/include/drm/drm_file.h +++ b/include/drm/drm_file.h @@ -34,8 +34,6 @@ #include <linux/completion.h> #include <linux/idr.h>
-#include <uapi/drm/drm.h>
#include <drm/drm_prime.h>
struct dma_fence;
@@ -227,7 +225,7 @@ struct drm_file { struct pid *pid;
/** @magic: Authentication magic, see @authenticated. */
- drm_magic_t magic;
unsigned int magic;
/**
- @lhead: