diff --git a/drivers/gpu/drm/tegra/drm.c b/drivers/gpu/drm/tegra/drm.c index e549afe..fa16048 100644 --- a/drivers/gpu/drm/tegra/drm.c +++ b/drivers/gpu/drm/tegra/drm.c @@ -36,8 +36,8 @@ static int tegra_drm_load(struct drm_device *drm, unsigned long flags)
if (iommu_present(&platform_bus_type)) { tegra->domain = iommu_domain_alloc(&platform_bus_type);
if (IS_ERR(tegra->domain)) {
err = PTR_ERR(tegra->domain);
if (!tegra->domain) {
}err = -ENOMEM; goto free;
Oh, good catch. Applied, thanks.
How do you think about to amend the commit title?
Is the following wording more appropriate? drm/tegra: Checking for NULL pointer instead of IS_ERR() usage
Regards, Markus