On Tue, Jul 13, 2021 at 9:33 PM Sam Ravnborg sam@ravnborg.org wrote:
Make it obvious that mode_fixup is deprecated and new drivers shall use atomic_check.
Signed-off-by: Sam Ravnborg sam@ravnborg.org Cc: Laurent Pinchart laurent.pinchart@ideasonboard.com Cc: Andrzej Hajda a.hajda@samsung.com Cc: Maarten Lankhorst maarten.lankhorst@linux.intel.com Cc: Maxime Ripard mripard@kernel.org Cc: Thomas Zimmermann tzimmermann@suse.de Cc: David Airlie airlied@linux.ie Cc: Daniel Vetter daniel@ffwll.ch
include/drm/drm_bridge.h | 3 +++ 1 file changed, 3 insertions(+)
diff --git a/include/drm/drm_bridge.h b/include/drm/drm_bridge.h index 46bdfa48c413..668f14234459 100644 --- a/include/drm/drm_bridge.h +++ b/include/drm/drm_bridge.h @@ -136,6 +136,9 @@ struct drm_bridge_funcs { * * NOTE: *
* This is deprecated, do not use!
* New drivers shall use &drm_bridge_funcs.atomic_check.
Bit a bikeshed, but in the rendered text this will be one line, I'd just merge it. Also since this is a reference within the same struct just use @atomic_check.
Now the real review: There's a pile more of these in drm_modeset_helper_vtables.h (well in crtc and encoder funcs, so only two, a small pile). Can you pls fix those up too? With that:
Reviewed-by: Daniel Vetter daniel.vetter@ffwll.ch
* * This function is called in the check phase of atomic modesets, which * can be aborted for any reason (including on userspace's request to * just check whether a configuration would be possible). Drivers MUST
-- 2.30.2