Hi Sam,
On Sat, Jan 18, 2020 at 3:04 PM Sam Ravnborg sam@ravnborg.org wrote:
The LVDS panel driver has almost everything which is required to describe a simple parallel RGB panel (also known as DPI, Display Pixel Interface).
There are a few high-level things we need to have sorted out.
The driver, when this patch is added, assumes that certain properties are now mandatory when using the panel-dpi compatible.
- data-mapping
- width-mm
- height-mm
- panel-timing
But this does not match the panel-dpi binding. So we need the panel-dpi binding updated first.
The current driver specify the connector type in drm_panel_init(). But a DPI panel is assumed to use a DRM_MODE_CONNECTOR_DPI, and not a DRM_MODE_CONNECTOR_LVDS. So the drm_panel_init() call needs to take into account the type of binding.
Thanks, I'll fix it in 2nd version.
@@ -257,7 +279,7 @@ static struct platform_driver panel_lvds_driver = { .probe = panel_lvds_probe, .remove = panel_lvds_remove, .driver = {
.name = "panel-lvds",
.name = "panel-generic",
I think changing the name of the driver like this is an UAPI change, which is not OK
I see 2 simple ways there: - keep the original platform driver name; - fork panel-lvds driver as panel-generic driver with dpi support.
What solution do you prefer?
.of_match_table = panel_lvds_of_table, },
};
Sam
-- Best regards Oleksandr Suvorov
Toradex AG Altsagenstrasse 5 | 6048 Horw/Luzern | Switzerland | T: +41 41 500 4800 (main line)