On Thu, 27 Jan 2022 21:01:35 +0100, Stephen Boyd wrote:
Use an aggregate driver instead of component ops so that we can get proper driver probe ordering of the aggregate device with respect to all the component devices that make up the aggregate device.
Cc: Jaroslav Kysela perex@perex.cz Cc: Takashi Iwai tiwai@suse.com Cc: Kai Vehmanen kai.vehmanen@linux.intel.com Cc: Daniel Vetter daniel.vetter@ffwll.ch Cc: "Rafael J. Wysocki" rafael@kernel.org Cc: Rob Clark robdclark@gmail.com Cc: Russell King rmk+kernel@arm.linux.org.uk Cc: Saravana Kannan saravanak@google.com Signed-off-by: Stephen Boyd swboyd@chromium.org
The patch looks good, but just a minor concern:
+static struct aggregate_driver hdac_aggregate_driver = {
- .probe = hdac_component_master_bind,
- .remove = hdac_component_master_unbind,
- .driver = {
.name = "hdac_agg",
Shouldn't we define some standard name scheme? This one has "hdac_agg", while the patch for HD-audio Realtek stuff has "realtek_aggregate".
(And maybe the latter one should be something like "hda_realtek_agg" or such, as Realtek covers pretty different devices and there might be conflict in future.)
With those considered: please take my ack Acked-by: Takashi Iwai tiwai@suse.de
thanks,
Takashi