To be future-proof and for better readability the time comparisons are modified to use time_before() instead of plain, error-prone math.
Signed-off-by: Manuel Schölling manuel.schoelling@gmx.de --- drivers/gpu/drm/radeon/radeon_pm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c index f30b842..b08db66 100644 --- a/drivers/gpu/drm/radeon/radeon_pm.c +++ b/drivers/gpu/drm/radeon/radeon_pm.c @@ -1592,7 +1592,7 @@ static void radeon_dynpm_idle_work_handler(struct work_struct *work) * to false since we want to wait for vbl to avoid flicker. */ if (rdev->pm.dynpm_planned_action != DYNPM_ACTION_NONE && - jiffies > rdev->pm.dynpm_action_timeout) { + time_before(rdev->pm.dynpm_action_timeout, jiffies)) { radeon_pm_get_dynpm_state(rdev); radeon_pm_set_clocks(rdev); }
On Wed, May 21, 2014 at 07:39:37PM +0200, Manuel Schölling wrote:
To be future-proof and for better readability the time comparisons are modified to use time_before() instead of plain, error-prone math.
Nit: commit messages are best wrapped around column 72.
Signed-off-by: Manuel Schölling manuel.schoelling@gmx.de
drivers/gpu/drm/radeon/radeon_pm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/radeon/radeon_pm.c b/drivers/gpu/drm/radeon/radeon_pm.c index f30b842..b08db66 100644 --- a/drivers/gpu/drm/radeon/radeon_pm.c +++ b/drivers/gpu/drm/radeon/radeon_pm.c @@ -1592,7 +1592,7 @@ static void radeon_dynpm_idle_work_handler(struct work_struct *work) * to false since we want to wait for vbl to avoid flicker. */ if (rdev->pm.dynpm_planned_action != DYNPM_ACTION_NONE &&
jiffies > rdev->pm.dynpm_action_timeout) {
}time_before(rdev->pm.dynpm_action_timeout, jiffies)) { radeon_pm_get_dynpm_state(rdev); radeon_pm_set_clocks(rdev);
I think time_after(jiffies, rdev->pm.dynpm_action_timeout) would be more intuitive, but either way:
Reviewed-by: Thierry Reding treding@nvidia.com
dri-devel@lists.freedesktop.org