Hi!
Follow-up on the v5 [1], things have gotten significantly better in the last 9 months, thanks to the efforts on Bifrost support by the Collabora team (and probably others I'm not aware of).
I've been testing this series on a MT8183/kukui device, with a chromeos-5.10 kernel [2], and got basic Chromium OS UI up with mesa 20.3.2 (lots of artifacts though).
devfreq is currently not supported, as we'll need: - Clock core support for switching the GPU core clock (see 2/4). - Platform-specific handling of the 2-regulator (see 3/4).
Since the latter is easy to detect, patch 3/4 just disables devfreq if the more than one regulator is specified in the compatible matching table.
[1] https://patchwork.kernel.org/project/linux-mediatek/cover/20200306041345.259... [2] https://crrev.com/c/2608070
Changes in v11: - binding: power-domain-names not power-domainS-names - mt8183*.dts: remove incorrect supply-names
Changes in v10: - Fix the binding to make sure sram-supply property can be provided.
Changes in v9: - Explain why devfreq needs to be disabled for GPUs with >1 regulators.
Changes in v8: - Use DRM_DEV_INFO instead of ERROR
Changes in v7: - Fix GPU ID in commit message - Fix GPU ID in commit message
Changes in v6: - Rebased, actually tested with recent mesa driver. - Add gpu regulators to kukui dtsi as well. - Power domains are now attached to spm, not scpsys - Drop R-B. - devfreq: New change - Context conflicts, reflow the code. - Use ARRAY_SIZE for power domains too.
Changes in v5: - Rename "2d" power domain to "core2" - Rename "2d" power domain to "core2" (keep R-B again). - Change power domain name from 2d to core2.
Changes in v4: - Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor) - Add power-domain-names to describe the 3 domains. (kept Alyssa's reviewed-by as the change is minor) - Add power domain names.
Changes in v3: - Match mt8183-mali instead of bifrost, as we require special handling for the 2 regulators and 3 power domains.
Changes in v2: - Use sram instead of mali_sram as SRAM supply name. - Rename mali@ to gpu@.
Nicolas Boichat (4): dt-bindings: gpu: mali-bifrost: Add Mediatek MT8183 arm64: dts: mt8183: Add node for the Mali GPU drm/panfrost: devfreq: Disable devfreq when num_supplies > 1 drm/panfrost: Add mt8183-mali compatible string
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++ arch/arm64/boot/dts/mediatek/mt8183-evb.dts | 5 + .../arm64/boot/dts/mediatek/mt8183-kukui.dtsi | 5 + arch/arm64/boot/dts/mediatek/mt8183.dtsi | 105 ++++++++++++++++++ drivers/gpu/drm/panfrost/panfrost_devfreq.c | 9 ++ drivers/gpu/drm/panfrost/panfrost_drv.c | 10 ++ 6 files changed, 162 insertions(+)
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org ---
Changes in v11: - binding: power-domain-names not power-domainS-names
Changes in v10: - Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: - Rebased, actually tested with recent mesa driver.
Changes in v5: - Rename "2d" power domain to "core2"
Changes in v4: - Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
diff --git a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml index 184492162e7e..3e758f88e2cd 100644 --- a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml +++ b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml @@ -17,6 +17,7 @@ properties: items: - enum: - amlogic,meson-g12a-mali + - mediatek,mt8183-mali - realtek,rtd1619-mali - rockchip,px30-mali - const: arm,mali-bifrost # Mali Bifrost GPU model/revision is fully discoverable @@ -41,6 +42,8 @@ properties:
mali-supply: true
+ sram-supply: true + operating-points-v2: true
power-domains: @@ -87,6 +90,31 @@ allOf: then: required: - resets + - if: + properties: + compatible: + contains: + const: mediatek,mt8183-mali + then: + properties: + power-domains: + description: + List of phandle and PM domain specifier as documented in + Documentation/devicetree/bindings/power/power_domain.txt + minItems: 3 + maxItems: 3 + power-domain-names: + items: + - const: core0 + - const: core1 + - const: core2 + required: + - sram-supply + - power-domains + - power-domain-names + else: + properties: + sram-supply: false
examples: - |
On Tue, 26 Jan 2021 09:17:56 +0800, Nicolas Boichat wrote:
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org
Changes in v11:
- binding: power-domain-names not power-domainS-names
Changes in v10:
- Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6:
- Rebased, actually tested with recent mesa driver.
Changes in v5:
- Rename "2d" power domain to "core2"
Changes in v4:
- Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
Please add Acked-by/Reviewed-by tags when posting new versions. However, there's no need to repost patches *only* to add the tags. The upstream maintainer will do that for acks received on the version they apply.
If a tag was not added on purpose, please state why and what changed.
On Sat, Feb 6, 2021 at 1:55 AM Rob Herring robh@kernel.org wrote:
On Tue, 26 Jan 2021 09:17:56 +0800, Nicolas Boichat wrote:
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org
Changes in v11:
- binding: power-domain-names not power-domainS-names
Changes in v10:
- Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6:
- Rebased, actually tested with recent mesa driver.
Changes in v5:
- Rename "2d" power domain to "core2"
Changes in v4:
- Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
Please add Acked-by/Reviewed-by tags when posting new versions. However, there's no need to repost patches *only* to add the tags. The upstream maintainer will do that for acks received on the version they apply.
If a tag was not added on purpose, please state why and what changed.
There were changes in v11, I thought you'd want to review again?
Anyway, I can resend a v12 with all the Rb/Ab if that works better for you.
On Fri, Feb 5, 2021 at 9:02 PM Nicolas Boichat drinkcat@chromium.org wrote:
On Sat, Feb 6, 2021 at 1:55 AM Rob Herring robh@kernel.org wrote:
On Tue, 26 Jan 2021 09:17:56 +0800, Nicolas Boichat wrote:
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org
Changes in v11:
- binding: power-domain-names not power-domainS-names
Changes in v10:
- Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6:
- Rebased, actually tested with recent mesa driver.
Changes in v5:
- Rename "2d" power domain to "core2"
Changes in v4:
- Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
Please add Acked-by/Reviewed-by tags when posting new versions. However, there's no need to repost patches *only* to add the tags. The upstream maintainer will do that for acks received on the version they apply.
If a tag was not added on purpose, please state why and what changed.
There were changes in v11, I thought you'd want to review again?
Looked like a minor change from the changelog, so it would have been appropriate to keep. However, I see another issue.
Rob
On Mon, Jan 25, 2021 at 7:18 PM Nicolas Boichat drinkcat@chromium.org wrote:
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org
Changes in v11:
- binding: power-domain-names not power-domainS-names
Changes in v10:
- Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6:
- Rebased, actually tested with recent mesa driver.
Changes in v5:
- Rename "2d" power domain to "core2"
Changes in v4:
- Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
diff --git a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml index 184492162e7e..3e758f88e2cd 100644 --- a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml +++ b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml @@ -17,6 +17,7 @@ properties: items: - enum: - amlogic,meson-g12a-mali
- mediatek,mt8183-mali - realtek,rtd1619-mali - rockchip,px30-mali - const: arm,mali-bifrost # Mali Bifrost GPU model/revision is fully discoverable
@@ -41,6 +42,8 @@ properties:
mali-supply: true
sram-supply: true
operating-points-v2: true
power-domains:
@@ -87,6 +90,31 @@ allOf: then: required: - resets
- if:
properties:
compatible:
contains:
const: mediatek,mt8183-mali
- then:
properties:
power-domains:
description:
List of phandle and PM domain specifier as documented in
Documentation/devicetree/bindings/power/power_domain.txt
minItems: 3
maxItems: 3
This won't work because the top level schema restricts this to 1. The top level needs to say:
power-domains: minItems: 1 maxItems: 3
And you need just 'minItems: 3' here and 'maxItems: 1' in the else clause.
And drop the description. That's every 'power-domains' property.
power-domain-names:
items:
- const: core0
- const: core1
- const: core2
Blank line
required:
- sram-supply
- power-domains
- power-domain-names
- else:
properties:
sram-supply: false
examples:
- |
-- 2.30.0.280.ga3ce27912f-goog
On Tue, Apr 20, 2021 at 9:01 PM Rob Herring robh@kernel.org wrote:
On Mon, Jan 25, 2021 at 7:18 PM Nicolas Boichat drinkcat@chromium.org wrote:
Define a compatible string for the Mali Bifrost GPU found in Mediatek's MT8183 SoCs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org
Changes in v11:
- binding: power-domain-names not power-domainS-names
Changes in v10:
- Fix the binding to make sure sram-supply property can be provided.
Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6:
- Rebased, actually tested with recent mesa driver.
Changes in v5:
- Rename "2d" power domain to "core2"
Changes in v4:
- Add power-domain-names description (kept Alyssa's reviewed-by as the change is minor)
Changes in v3: None Changes in v2: None
.../bindings/gpu/arm,mali-bifrost.yaml | 28 +++++++++++++++++++ 1 file changed, 28 insertions(+)
diff --git a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml index 184492162e7e..3e758f88e2cd 100644 --- a/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml +++ b/Documentation/devicetree/bindings/gpu/arm,mali-bifrost.yaml @@ -17,6 +17,7 @@ properties: items: - enum: - amlogic,meson-g12a-mali
- mediatek,mt8183-mali - realtek,rtd1619-mali - rockchip,px30-mali - const: arm,mali-bifrost # Mali Bifrost GPU model/revision is fully discoverable
@@ -41,6 +42,8 @@ properties:
mali-supply: true
sram-supply: true
operating-points-v2: true
power-domains:
@@ -87,6 +90,31 @@ allOf: then: required: - resets
- if:
properties:
compatible:
contains:
const: mediatek,mt8183-mali
- then:
properties:
power-domains:
description:
List of phandle and PM domain specifier as documented in
Documentation/devicetree/bindings/power/power_domain.txt
minItems: 3
maxItems: 3
This won't work because the top level schema restricts this to 1. The top level needs to say:
power-domains: minItems: 1 maxItems: 3
And you need just 'minItems: 3' here and 'maxItems: 1' in the else clause.
And drop the description. That's every 'power-domains' property.
power-domain-names:
items:
- const: core0
- const: core1
- const: core2
Blank line
Thanks, hopefully all fixed in v12.
required:
- sram-supply
- power-domains
- power-domain-names
- else:
properties:
sram-supply: false
examples:
- |
-- 2.30.0.280.ga3ce27912f-goog
GPUs with more than a single regulator (e.g. G72 on MT8183) will require platform-specific handling for devfreq, for 2 reasons: 1. The opp core (drivers/opp/core.c:_generic_set_opp_regulator) does not support multiple regulators, so we'll need custom handlers. 2. Generally, platforms with 2 regulators have platform-specific constraints on how the voltages should be set (e.g. minimum/maximum voltage difference between them), so we should not just create generic handlers that simply change the voltages without taking care of those constraints.
Disable devfreq for now on those GPUs.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org Reviewed-by: Tomeu Vizoso tomeu.vizoso@collabora.com Reviewed-by: Steven Price steven.price@arm.com ---
Changes in v11: None Changes in v10: None Changes in v9: - Explain why devfreq needs to be disabled for GPUs with >1 regulators.
Changes in v8: - Use DRM_DEV_INFO instead of ERROR
Changes in v7: - Fix GPU ID in commit message
Changes in v6: - devfreq: New change
Changes in v5: None Changes in v4: None Changes in v3: None Changes in v2: None
drivers/gpu/drm/panfrost/panfrost_devfreq.c | 9 +++++++++ 1 file changed, 9 insertions(+)
diff --git a/drivers/gpu/drm/panfrost/panfrost_devfreq.c b/drivers/gpu/drm/panfrost/panfrost_devfreq.c index 7c5ffc81dce1..a544ae1e560a 100644 --- a/drivers/gpu/drm/panfrost/panfrost_devfreq.c +++ b/drivers/gpu/drm/panfrost/panfrost_devfreq.c @@ -93,6 +93,15 @@ int panfrost_devfreq_init(struct panfrost_device *pfdev) struct thermal_cooling_device *cooling; struct panfrost_devfreq *pfdevfreq = &pfdev->pfdevfreq;
+ if (pfdev->comp->num_supplies > 1) { + /* + * GPUs with more than 1 supply require platform-specific handling: + * continue without devfreq + */ + DRM_DEV_INFO(dev, "More than 1 supply is not supported yet\n"); + return 0; + } + opp_table = dev_pm_opp_set_regulators(dev, pfdev->comp->supply_names, pfdev->comp->num_supplies); if (IS_ERR(opp_table)) {
Add support for MT8183's G72 Bifrost.
Signed-off-by: Nicolas Boichat drinkcat@chromium.org Reviewed-by: Tomeu Vizoso tomeu.vizoso@collabora.com Reviewed-by: Steven Price steven.price@arm.com ---
Changes in v11: None Changes in v10: None Changes in v9: None Changes in v8: None Changes in v7: - Fix GPU ID in commit message
Changes in v6: - Context conflicts, reflow the code. - Use ARRAY_SIZE for power domains too.
Changes in v5: - Change power domain name from 2d to core2.
Changes in v4: - Add power domain names.
Changes in v3: - Match mt8183-mali instead of bifrost, as we require special handling for the 2 regulators and 3 power domains.
Changes in v2: None
drivers/gpu/drm/panfrost/panfrost_drv.c | 10 ++++++++++ 1 file changed, 10 insertions(+)
diff --git a/drivers/gpu/drm/panfrost/panfrost_drv.c b/drivers/gpu/drm/panfrost/panfrost_drv.c index 83a461bdeea8..ca07098a6141 100644 --- a/drivers/gpu/drm/panfrost/panfrost_drv.c +++ b/drivers/gpu/drm/panfrost/panfrost_drv.c @@ -665,6 +665,15 @@ static const struct panfrost_compatible amlogic_data = { .vendor_quirk = panfrost_gpu_amlogic_quirk, };
+const char * const mediatek_mt8183_supplies[] = { "mali", "sram" }; +const char * const mediatek_mt8183_pm_domains[] = { "core0", "core1", "core2" }; +static const struct panfrost_compatible mediatek_mt8183_data = { + .num_supplies = ARRAY_SIZE(mediatek_mt8183_supplies), + .supply_names = mediatek_mt8183_supplies, + .num_pm_domains = ARRAY_SIZE(mediatek_mt8183_pm_domains), + .pm_domain_names = mediatek_mt8183_pm_domains, +}; + static const struct of_device_id dt_match[] = { /* Set first to probe before the generic compatibles */ { .compatible = "amlogic,meson-gxm-mali", @@ -681,6 +690,7 @@ static const struct of_device_id dt_match[] = { { .compatible = "arm,mali-t860", .data = &default_data, }, { .compatible = "arm,mali-t880", .data = &default_data, }, { .compatible = "arm,mali-bifrost", .data = &default_data, }, + { .compatible = "mediatek,mt8183-mali", .data = &mediatek_mt8183_data }, {} }; MODULE_DEVICE_TABLE(of, dt_match);
dri-devel@lists.freedesktop.org